All Platform Users receive an error when accessing the platform

Incident Report for Precision Autonomy

Resolved

The incident has been verified and is now resolved.
Posted Nov 21, 2024 - 04:00 UTC

Monitoring

Brokers and Underwriters now appear to be able to access the platform as normal.
Our team will continue monitoring and verify prior to closing the incident.
More details to follow.
Posted Nov 21, 2024 - 03:49 UTC

Update

We are continuing to investigate this issue.
Posted Nov 21, 2024 - 03:34 UTC

Investigating

Brokers & Insureds are receiving an error when trying to access the Proposal Collection UI.
Underwriters are receiving an error when trying to load the Referral UI, Hold Cover UI and the Incident Report UI.
Our team is investigating and will update as soon as possible.
Posted Nov 21, 2024 - 03:28 UTC
This incident affected: Proposal Collection and Underwriter Portal (Manage Referrals, Hold Cover, View Incidents, Underwriter Portfolio Management Portal).