Unable to submit proposals

Incident Report for Precision Autonomy

Resolved

This incident has been resolved.
Posted Aug 26, 2024 - 12:00 UTC

Investigating

We are currently experiencing an issue causing some users to be unable to submit an insurance proposal for drone products. We apologise for any inconvenience and are currently investigating the issue.
Posted Aug 26, 2024 - 08:01 UTC
This incident affected: Proposal Collection.